3

I have the English fourth edition 2007 base game of Settlers of Catan. Are current editions of the expansion, specifically Catan: Seafarers English edition 2015, compatible with this base set?

  • I believe the differences are mostly in the provided rules and (depending on version) color of player tokens. It should be unproblematic to use expansions cross version – npst Apr 6 '17 at 8:34
3

When the 5th edition of Catan came out, I remember reading an official source (Catan FAQ) explaining that it would be completely backwards compatible. The only source I can find right now is this one:

The 5th edition will also be fully backwards compatible to the previous 4th edition and will feature a more cohesive art style throughout all 4th and 5th edition expansions.

It looks a bit odd though, using different editions. So at that time I decided to buy all the old sets while they were still available. It's functionally possible to combine different editions into 1 game, but not aesthetically correct :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.